Home » , , , , , , » Instalar Whatsapp en Fedora 21 / Install Whatsapp on Fedora 21

Instalar Whatsapp en Fedora 21 / Install Whatsapp on Fedora 21

Written By @dmin on 18 ene. 2015 | 1/18/2015

¿Como instalar WhatsApp en Fedora 21? 

¿How to install WhatsApp on Fedora 21?


En esté post les dejaré una guía de como instalar Whatsapp con Pidgin en Fedora 21...

1. Instalar pidgin y wget.
sudo yum install wget pidgin -y
2. Descargar el repo para instalar whatsapp-purple
sudo wget https://copr.fedoraproject.org/coprs/davidgf/whatsapp-purple/repo/fedora-rawhide/davidgf-whatsapp-purple-fedora-rawhide.repo  -O /etc/yum.repos.d/whatsapp.repo
3. Instalar whatsapp-purple.
sudo yum install whatsapp-purple -y
4. Descargar el siguiente repo para instalar python-yowsup.
sudo wget http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_20/home:zhonghuaren.repo -O /etc/yum.repos.d/rpm-sphere.repo
El archivo contiene lo siguiente:
[home_zhonghuaren]
name=RPM Sphere (Fedora_20)
type=rpm-md
baseurl=http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_20/
gpgcheck=1
gpgkey=http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_20/repodata/repomd.xml.key
enabled=1
5. Editar el archivo con el editor de texto de su preferencia, para Fedora 21.
sudo vi /etc/yum.repos.d/rpm-sphere.repo
Debe quedar así:
[home_zhonghuaren]
name=RPM Sphere (Fedora_21)
type=rpm-md
baseurl=http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_21/
gpgcheck=1
gpgkey=http://download.opensuse.org/repositories/home:/zhonghuaren/Fedora_21/repodata/repomd.xml.key
enabled=1
6. Instalar python-yowsup
   sudo yum install python-yowsup -y
7. Descargar y descomprimir el siguiente archivo.
wget https://github.com/tgalal/yowsup/archive/master.zip 
unzip master.zip
8. Ingresar a la carpeta descomprimida
cd yowsup-master/
9. Dar permisos de ejecución.
chmod +x yowsup-cli
10. Solicitamos nuestro código para nuestro WhatsApp
 ./yowsup-cli registration --requestcode sms --phone CCXXXXXXXX --cc XX --mcc XXX --mnc XXX
CCXXXXXXXXXX=Código de País + 10 digitos del móvil
cc= Código del país.
mcc=Código móvil del país.
mnc=Código de la red.
NOTA: sms puede ser sustituido por voice, para recibir el código por llamada.

Ejemplo de solicitud por SMS para México:
./yowsup-cli registration --requestcode sms --phone 529850000000 --cc 52 --mcc 334 --mnc 020
Nos llegará un código a nuestro móvil.

11. Solicitar una contraseña con el código recibido:
./yowsup-cli registration --register xxxxxx --phone CCXXXXXXXX --cc XX
Ejemplo para México:
./yowsup-cli registration --register 935618 --phone 529850000000 --cc 52

Del resultado de este comando, nos servirá el passowrd (pw) y el nombre de usuario (login)



12. Abrir Pidgin y configurar la cuenta de WhatsApp con los datos obtenidos en el paso 11.

Pidgin funcionando con el Protocolo de WhatsApp en Fedora 21.
Running WhatsApp in Fedora 21. :)


 Comenten si les sirvió.
:)

Sígueme: 
Mi Facebook TuxFed.
Mi Twitter TuxFed 
Mi YouTube TuxFed

4 comentarios:

  1. Buenísimo.. Me ayudo con mi problema para instalar python-yowsup. up's no soy usuario avanzado xD xD pero ya lo probé, se logeo sin problema, solo un detalle, no me aparecen los contactos, supongo es normal porque esta vinculado al Smarphon. pero también tenia algunos grupos y estos si me los respeto, aunque solo me aparecían los números telefónicos. pero todo bien, pude mensaje-ar. Ha y en el Smartphone ya no funciono xD xD xD.
    Sludos!!!!!

    ResponderEliminar
    Respuestas
    1. Este comentario ha sido eliminado por el autor.

      Eliminar
    2. aaaahhh!!! recomiendo visitar esta pagina para comprobar los datos de MCC (mobile country code) y MNC (mobile network code) :) :)

      https://en.wikipedia.org/wiki/Mobile_country_code#M

      Eliminar
  2. Hola, estoy trabajando en fedora 22 y me ha dado un error al instalar el python-yowsup, me dice:

    Último chequeo de expiración de metadata comprobado hace 0:33:54 el Sat Oct 3 14:17:47 2015
    Error: nothing provides /bin/python needed by python-yowsup-2.3.124-4.1.noarch
    (try to add '--allowerasing' to command line to replace conflicting packages)

    ¿cómo puedo solucionarlo?

    Muchas gracias

    ResponderEliminar

Comenta respetando al autor del post y a los lectores.
Puedes comentar como anónimo, pero tendrás que estar al pendiente, visitando el post para saber si te respondí, si quieres que la respuesta llegue a tu correo, comenta utilizando algunos de los servicios disponibles, o puedes preguntar en mis redes sociales.

Translate

Visita mi Canal de Youtube.

Todo el contenido está disponible bajo los términos de la licencia Creative Commons. Con la tecnología de Blogger.